1. Uruchamianie programu Modeller

Komentarze

Transkrypt

1. Uruchamianie programu Modeller
1. Uruchamianie programu Modeller
W menu Start systemu MS Windows, w katalogu Programy naleŜy odnaleźć
katalog Vector Fields Opera, a w nim program Opera 12.0 i uruchomić go:
Start → Programy → Vector Fields Opera → Opera 12.0
Zostanie uruchomione okno MenadŜera pakietu OPERA 2D/3D.
Z menu głównego MenadŜera naleŜy wybrać polecenie ładujące klucz licencji programu:
Options → Licensing → Set Dongle Type → Network
Rys. 1-1 Okno dialogowe z komunikatem poprawnie załadowanego klucza licencji programu.
Po pojawieniu się okna z komunikatem (Rys. 1-1) wcisnąć przycisk OK.
Gdy licencja jest załadowana poprawnie moŜna uruchomić program Modeller.
Z menu górnego wybrać:
Opera-3D → Modeller
Przy pierwszym uruchomieniu programu pojawi się okno dialogowe, w którym moŜna
ustawić folder roboczy słuŜący do przechowywania plików z modelami i wynikami obliczeń
(Rys. 1-2).
Rys. 1-2 Okno dialogowe słuŜące do wskazania folderu roboczego.
Okno programu Modeller po uruchomieniu przedstawia Rys. 1-3.
3
Menu górne
Paski
narzędziowe
Osie układu współrzędnych
Menu podręczne
Pasek stanu
Rys. 1-3 Okno programu Modeller.
4
2. Elektromagnes ze zworą obrotową
W ćwiczeniu przedstawiony zostanie zastosowanie solvera TOSCA Magnetic
do obliczeń pola magnetostatycznego w elektromagnesie ze zworą obrotową.
Omówiony zostanie sposób budowy modelu polowego badanego elektromagnesu oraz
przygotowanie pliku obliczeniowego w programie Modeller. Natomiast w programie
Post-Processor przedstawiona zostanie analiza wyników obliczeń, pokazane zostaną
moŜliwości wizualizacji wyników oraz obliczanie momentu działającego na zworę.
Na Rys. 2-1 przedstawiono wygląd modelowanego elektromagnesu.
Rys. 2-1 Model bryłowy elektromagnesu ze zworą obrotową.
5
2.1. Budowa modelu i przygotowanie symulacji
2.1.1.
Budowa modelu bryłowego
Rdzeń elektromagnesu zostanie utworzony z dwóch prostopadłościanów, natomiast
kształt zwory zostanie określony przy pomocy walców, które utworzą takŜe szczelinę
powietrzną pomiędzy zworą a rdzeniem. Model bryłowy powstanie po zsumowaniu
wszystkich brył składowych z zachowaniem komórek oraz wyodrębnieniu ruchomej części
elektromagnesu, czyli zwory. Parametry poszczególnych brył przedstawione zostały
w Tab. 2-1.
Model elektromagnesu zostanie tak utworzony, Ŝe oś obrotu zwory zostanie
umieszczona w osi Z globalnego układu współrzędnych.
Tab. 2-1 Parametry brył tworzących rdzeń i zworę elektromagnesu.
Name
rdzen1
rdzen2
Name
walec1
walec2
walec3
First corner
x=-45
y=-30
z=-5
x=-35
y=-20
z=-5
Centre of base
x=0
y=0
z=-5
x=0
y=0
z=-5
x=0
y=0
z=-5
Opposite corner
x=5
y=30
z=5
x=-5
y=20
z=5
Centre of top
Radius
x=0
12
y=0
z=5
x=0
12.25
y=0
z=5
x=0
12.5
y=0
z=5
Wybrać z paska narzędziowego ikonę
lub z menu górnego: Create → Object → Block
i nacisnąć OK.
6
W podobny sposób narysować drugi prostopadłościan tworzący rdzeń.
Wybrać z paska narzędziowego ikonę
lub z menu górnego: Create → Object → Cylinder/Cone
i nacisnąć OK.
W podobny sposób narysować pozostałe dwa walce.
7
Wybrać z paska narzędziowego ikonę
i
lub z menu górnego: Picking → Pick Bodies i Picking → Pick All
Filter Type Entities
Zostaną zaznaczone
utworzone bryły.
wszystkie
Z menu podręcznego wybrać: Combine Bodies → Union, without
regularization
lub z menu górnego: Operations → Combine Bodies → Union, without
regularization.
W wyniku operacji sumowania
zostanie utworzona jedna bryła,
ale zostaną zachowane wewnątrz
niej ściany brył składowych
i utworzą się komórki.
8
Wybrać z paska narzędziowego ikonę
lub z menu górnego: Picking → Pick Cells
Zaznaczyć szczelinę powietrzną,
powietrze wokół zwory i zworę jako
komórki.
Z menu podręcznego wybrać: Extract Cells
lub z menu górnego: Operations → Extract Cells
Zaznaczone
komórki
zostały
wyodrębnione z bryły i stały się
osobnymi bryłami.
W utworzonym modelu uwzględnione są wszystkie części elektromagnesu, a takŜe
szczelina powietrzna w kształcie dwóch pierścieni. Pierścienie te składają się z kilku
komórek. W następnym etapie komórki te zostaną połączone w jedną. Taka budowa szczeliny
powietrznej jest konieczna ze względu na obliczanie momentu działającego na zworę.
9
Wybrać z paska narzędziowego ikonę
lub z menu górnego: Picking → Pick Bodies
Zaznaczyć
bryły
tworzące
pierścień zewnętrzny.
Z menu podręcznego wybrać: Combine
Bodies
→
Union,
regularization
lub z menu górnego: Operations → Combine Bodies → Union,
regularization.
Pierścień zewnętrzny tworzy
jedna bryła z jedną komórką.
10
with
with
W podobny sposób scalić bryły tworzące pierścień wewnętrzny.
Zworę oraz otaczające ją powietrze naleŜy scalić w jedną bryłę ale z zachowaniem podziału
na komórki.
Wybrać z paska narzędziowego ikonę
lub z menu górnego: Picking → Pick Bodies
Zaznaczyć bryły tworzące zworę
oraz otaczające ją powietrze.
11
Z menu podręcznego wybrać: Combine
Bodies
→
Union,
without
regularization
lub z menu górnego: Operations → Combine Bodies → Union, without
regularization.
Zwora i powietrze tworzyć będą
jedną bryłę z 3 komórkami
12
2.1.2.
Parametry materiałów i komórek
W budowanym modelu oprócz powietrza występuje tylko jeden materiał: stal
krzemowa wykorzystana do budowy rdzenia i zwory. Z punktu widzenia analizy pola
magnetycznego istotnym parametrem tych materiałów jest przenikalność magnetyczna
względna. Dla materiału ferromagnetycznego jakim jest stal krzemowa zamiast
przenikalności magnetycznej względnej jako stałego parametru podaje się charakterystykę
magnesowania B=f(H). Przykładową charakterystykę magnesowania, która zostanie uŜyta
do obliczeń przedstawiono na Rys. 2-2.
Rys. 2-2 Charakterystyka magnesowania przyjęta do obliczeń.
Pierwszym krokiem będzie zdefiniowanie etykiet materiałów w komórkach, ustawione
zostaną takŜe parametry siatki oraz priorytety poszczególnych komórek. Kolejny etap
to przypisanie do tych etykiet odpowiednich parametrów materiałów.
Wybrać z paska narzędziowego ikonę
lub z menu górnego: Picking → Pick Cells
Zaznaczyć
rdzeń.
komórkę
tworzącą
13
Z menu podręcznego wybrać: Cell properties
lub z menu górnego: Properties → Cell properties
Analogicznie postąpić w przypadku pozostałych komórek
14
Zdefiniowanym etykietom moŜna przypisać odpowiednie parametry materiałów.
Jedynym materiałem, którego etykieta będzie dostępna jest materiał rdzenia i zwory.
Powietrze (Air) przyjmuje wartości domyślne – dla pola magnetycznego jest
to przenikalność magnetyczna względna równa 1.
Zanim jednak przypisanie parametrów etykietom zostanie dokonane, konieczne jest
wybranie odpowiedniego solvera. Do obliczeń pola magnetostatycznego w programie
OPERA 3D wykorzystuje się program TOSCA Magnetic.
Z menu górnego: Model → Analysis Type → TOSCA Magnetic
Z menu górnego: Model → Set Material Properties...
Dla etykiety stal krzemowa
zaznaczyć opcję nonlinear
i
wybrać
charakterystykę
domyślną Default, a następnie
nacisnąć przycisk Apply i OK.
15
Dla materiału rdzenia i zwory została przyjęta domyślna charakterystyka magnesowania
z programu Modeller – charakterystyka ta przedstawiona jest na Rys. 2-2.
2.1.3.
Tworzenie uzwojenia
Uzwojenie elektromagnesu zostanie zamodelowane przy pomocy predefiniowanych
(sparametryzowanych) uzwojeń. Spośród kilku rodzajów uzwojeń dostępnych w programie
Modeller wykorzystane zostanie uzwojenie typu Racetrack. Parametry tego uzwojenia
przedstawia Rys. 2-3.
Rys. 2-3 Parametry geometrii uzwojenia typu Racetrack.
X1 – Point on cross-section, X – współrzędna X przekroju poprzecznego
względem lokalnego układu współrzędnych,
Y1 – Point on cross-section, Y – współrzędna Y przekroju poprzecznego
względem lokalnego układu współrzędnych,
A – Cross-section, Width in x direction – szerokość cewki,
B – Cross-section, Thickness in y direction – grubość cewki,
H1 – Half length – połowa długości,
R1 – Arc radius – promień zaokrąglenia.
16
Wybrać z paska narzędziowego ikonę
lub z menu górnego: Create → Conductor → Racetrack...
Wybrać
zakładkę
Local
Coordinate
Systems
i zdefiniować lokalny układ
współrzędnych dla uzwojenia.
W
zakładce
Racetrack
Parameters
zdefiniować
wymiary uzwojenia.
W zakładce Source Drivers
zdefiniować
gęstość
prądu
w uzwojeniu. Przy danym
prądzie całkowitym pomocna
będzie zmienna area. W polu
Current density naleŜy
wpisać 2772/area.
Po wprowadzeniu parametrów
nacisnąć przycisk OK.
17
2.1.4.
Tło i warunki brzegowe
Ostatni etap budowy modelu to utworzenie tła – obszaru powietrza wokół
elektromagnesu i ustawieniu na jego zewnętrznych ścianach warunków brzegowych.
Z menu górnego: Model → Model symmetry...
Wybrać kształt tła (Shape of
background) typu Block
i w parametrze Block Scale
Factors wpisać 3 dla kaŜdego
z kierunków.
Wybrać zakładkę Far field
boundary conditions i dla
kaŜdej z powierzchni tła wybrać
warunek typu Tangential
magnetic.
Nacisnąć przycisk OK.
Tło pojawi się na etapie generowania siatki.
18
2.1.5.
Generowanie siatki elementów skończonych
Generowanie siatki elementów skończonych odbywa się w trzech etapach:
1. Tworzenie bryły modelu – wszystkie bryły scalane są w jedną bryłę modelu z
zachowaniem podziału na komórki.
2. Generowanie siatki powierzchniowej.
3. Generowanie siatki objętościowej.
Z menu górnego wybrać: Model → Create Model Body...
Operacja ta scala wszystkie bryły w
jedną bryłę, a takŜe tworzone jest tło
zdefiniowane
przy
pomocy
polecenia Model symmetry.
Z menu górnego wybrać: Model → Generate Surface Mesh...
Maksymalna wielkość elementu
siatki ustawiona zostanie na 20,
mniejsze
elementy
powstaną
w
poszczególnych
komórkach,
w których parametr określający
wielkość elementu został ustawiony.
Z menu górnego wybrać:
Model → Generate Volume Mesh...
19
2.2. Przygotowanie i uruchomienie obliczeń
Po ukończeniu budowy modelu kolejny etap to wprowadzenie odpowiednich ustawień
dla solvera i utworzenie pliku z bazą danych do obliczeń.
Z menu górnego wybrać: Model → TOSCA Magnetostatics Settings...
Zaznaczyć opcję Use nonlinear
properties,
oznaczającą
wykonanie
obliczeń
z uwzględnieniem nieliniowości
materiałów.
Z menu górnego wybrać: Model → Create Analysis Database...
Baza danych będzie utworzona
w
układzie
jednostek
SI
z jednostkami długości mm, nazwa
pliku to Zwora_obrotowa. Plik
będzie miał rozszerzenie .op3.
Aby utworzyć plik z bazą danych
do obliczeń i uruchomić obliczenia
naleŜy
po
wprowadzeniu
powyŜszych
ustawień
nacisnąć
przycisk Prepare and Solve.
20
2.3. Obliczenia w postprocesorze
Wizualizację wyników obliczeń oraz dodatkowe obliczenia moŜna wykonać w
programie Post-Processor. Uruchomienie Post-Procesora moŜliwe jest z poziomu programu
Modeller oraz z poziomu MenadŜera pakietu OPERA.
Zostanie wyświetlony rozkład modułu indukcji pola magnetostatycznego oraz
policzony moment działający na zworę. W programie Modeller Post-Processor uruchamiany
jest następująco:
Z menu górnego wybrać: Model → Launch Post-Processor
Po uruchomieniu postprocesora
zostanie
wczytany
ostatnio
policzony plik oraz wyświetlone
zostaną części modelu nie będące
powietrzem.
21
2.3.1.
Rozkład modułu indukcji
Rozkład dowolnej wielkości polowej moŜna wyświetlić w postaci rozkładu 3D oraz
w postaci wykresu wzdłuŜ odcinka, łuku lub po okręgu. MoŜliwe jest takŜe określenie
wartości tej wielkości w konkretnym punkcie modelu.
Wybrać z paska narzędziowego ikonę
lub z menu górnego wybrać: View → Select...
W oknie programu zaznaczyć grupę
Conductors, a następnie nacisnąć
kolejno:
Remove
from
selection i Select and
Refresh.
Po tych czynnościach widoczna
będzie część rdzenia przysłonięta
przez uzwojenie.
Wybrać z paska narzędziowego ikonę
lub z menu górnego wybrać: View → 3D Display...
Wybrać
opcję
Component
contours, a w polu Field
component
wpisać
Bmod
i nacisnąć przycisk OK.
22

Podobne dokumenty