SIECI KOMPUTEROWE

Komentarze

Transkrypt

SIECI KOMPUTEROWE
SIECI KOMPUTEROWE BIOTECHNOLOGIA
DWICZENIE 3 – BUDOWA SIECI LOKALNEJ – SYMULATOR DYDAKTYCZNY
1
SYMULATOR DYDAKTYCZNY PACKET TRACER
Zainstaluj aplikację Packet Tracer, a następnie zapoznaj się z jej funkcjonowaniem.
2
2.1
PODSTAWOWE POLECENIA KONFIGURACYJNE CISCO IOS, PODŁĄCZENIE KONSOLI
ZARZĄDZANIA ROUTEREM:
USTAWIENIA DLA PROGRAMU HYPERTERMINAL (A) ORAZ TERATERM PRO (B):
a)
2.2
STRUKTURA INTERFEJSU POLECEO ROUTERA:
2.3
KONFIGURACJA NAZWY HOSTA:
Router(config)# hostname NazwaRoutera
NazwaRoutera(config)#
b)
2.4
KONFIGURACJA HASEŁ:
o
o
o
o
2.5
Hasło konsoli:
Router(config)#line console
Router(config-line)#login
Router(config-line)#password haslo
Hasło wirtualnych terminali (telnet):
Router(config)#line vty 0 4
Router(config-line)#login
Router(config-line)#password haslo
Hasło trybu “privilidged”:
niezaszyfrowane:
Router(config)#enable password haslo
lub zaszyfrowane:
Router(config)#enable secret haslo
w przypadku gdy skonfigurujemy oba hasło aktywne jest hasł zaszyfrowane
Zaszyfrowanie wszystkich haseł:
Router(config)# service password-encryption
SHOW … SPRAWDZANIE BIEŻĄCEJ KONFIGURACJI:
show ? provides a list of available show commands
show interfaces – Displays all the statistics for all the interfaces on the router or Router#show
interfaces serial 0/1
show controllers serial – Displays information-specific to the interface hardware
show clock – Shows the time set in the router
show hosts – Displays a cached list of host names and addresses
show users – Displays all users who are connected to the router
show history – Displays a history of commands that have been entered
show flash – Displays information about flash memory and what IOS files are stored there
show version – Displays information about the router and the IOS that is running in RAM
show ARP – Displays the ARP table of the router
show protocol – Displays the global and interface specific status of any configured Layer 3 protocols
show startup-configuration – Displays the saved configuration located in NVRAM
show running-configuration – Displays the configuration currently running in RAM
2.6
KONFIGURACJA INTERFEJSÓW:
Konfigurację interfejsów rozpoczynamy od wyboru trybu konfiguracji odpowiedniego interfejsu w
globalnym trybie konfiguracyjnym:
R1(config)#interface typ slot/port
Dla interfejsu szeregowego 0/0 mamy:
R1(config)#interface serial 0/0
2.6.1 KONFIGURACJA INTERFEJSU SZEREGOWEGO
R1(config)#interface Serial0/0
R1(config-if)#ip address adres_interfejsu net_mask
R1(config-if)#clockrate wartosc – SYGNAŁ ZEGAROWY TYLKO DLA INTERFEJSU DCE!!
R1(config-if)#No shutdown – włączenie interfejsu
2.6.2 KONFIGURACJA INTERFEJSU FASTETHERNET
R1(config)# interface FastEthernet0/0
R1(config-if)#ip address adres_interfejsu net_mask
R1(config-if)#No shutdown – włączenie interfejsu
2.7
OPISY INTERFEJSÓW
Opis interfejsu ułatwia porządkowanie i logiczne zarządzanie konfiguracją urządzeo
R1(config)# interface typ slot/port
R1(config-if)#description tekst_opisu
2.8
HOSTNAME RESOLUTION
R1(config)# ip host nazwa host_address1 [host_address2…]
ZAPISYWANIE ZMIAN W KONFIGURACJI POLECENIE COPY
2.9
Roboczy plik konfiguracyjny po wprowadzeniu zmian przechowywany jest w pamięci RAM routera bieżącą
konfiguracje możemy sprawdzid poleceniem:
R1# show running-config
Konfiguracja jest również zapisana w pamięci nie ulotnej NVRAM (konfiguracja startowa) i możemy ją
wyświetlid za pomocą polecenia:
R1# show startup-config
W celu zachowania dokonanych zmian zapisujemy bieżącą konfigurację do pamięci NVRAM:
R1# copy running-config startup-config
Ogólnie polecenie copy ma postad:
R1# copy source destination
Możemy także kopiowad pliki do i z serwera tftp:
R1# copy running-config tftp
R1# copy flash tftp
R1# copy tftp startup-config tftp
2.10 KASOWANIE KONFIGURACJI
Aby skasowad istniejącą konfiguracje routera korzystamy z plecenia erase:
Router# erase startup-config
Router# reload
dla Cisco IOS 10.3:
Router# write erase
Router# reload
2.11 KONFIGURACJA ROUTINGU
Rodzaje routingu:
o
o
Routing statyczny – na stałe wprowadzona trasa wprowadzona przez administratora
Routing dynamiczny – trasy ustalane są przez odpowiedni protokół routingu, dostosowuje się do
zmiennych „warunków” w sieci.
2.12 KONFIGURACJE ROUTINGU STATYCZNEGO:
R1(config)#ip route siec_docelowa maska_sieci
{int_wychodzący|next_hop_addres}[distance_metric]
Np. :
R1(config)#ip route 172.16.3.0 255.255.255.0 Serial 0/0
Połączenie statyczne może byd wykorzystywane między innymi jako połączenie zapasowe (w przypadku gdy
zawiodą połączenia uzyskane dynamicznie).
W takim wypadku należy podad dystans administracyjny (distance_metric) o wartości wyższej niż dla
uzywanych protokołów routingu (domyślnie dla tras zapisanych statycznie wynosi on 1) np.:
R1(config)#ip route 172.16.3.0 255.255.255.0 172.16.4.1 130
2.13 GATEWAY OF LAST RESORT
R1(config)#ip route 0.0.0.0 0.0.0.0 {int_wychodzący|next_hop_addres}
2.14 ROUTING DYNAMICZNY
Protokoły routingu dynamicznego:
o
o
o
o
Routing Information Protocol (RIP)
Interior Gateway Routing Protocol (IGRP)
Enhanced Interior Gateway Routing Protocol (EIGRP)
Open Shortest Path First (OSPF)
2.14.1 KONFIGURACJA RIP
The router command starts a routing process.
The network command is required because it enables the routing process to determine which
interfaces participate in the sending and receiving of routing updates.
An example of a routing configuration is:
R1(config)#router rip
R2(config-router)#network 172.16.0.0
2.15 TESTOWANIE DZIAŁANIA ROUTINGU:
Polecenia przydatne do testowania działania routingu i protokołów routingu:
o
o
o
o
o
o
o
o
o
ping
traceroute
show ip router
debug ip RIP
show ip rip database
show ip protocols {summary}
show ip route
debug ip rip {events}
show ip interface briej
3
MODELOWANIE SIECI LOKALNEJ
1.
2.
3.
4.
5.
6.
4
Korzystając z oprogramowania Packet Tracer
zamodeluj o topologi pokazanej na Rysunek 1, w tym
celu wykorzystaj routery z serii 2800 oraz przełączniki
Catalyst 2960.
Zaproponowad schemat prywatnej adresacji sieciowej
dla klas 'A', 'B' oraz 'C'.
Wykonad podstawową konfigurację routerów dla
jednej z klas adresów, konfiguracja powinna zawierad
przynajmniej:
a. nazwę routera,
b. konfigurację haseł (hasła dla konsoli
i połaczen telnetowych ustawid na "cisco" a
hasło do trybu "enabled" na "class")
c. konfigurację interfejsów routerów (zgodnie Rysunek 1. Topologia sieci
zaproponowaną adresacją IP)
d. konfigurację tablicy hostów (Hostables),
e. konfigurację routingu dynamicznego RIP
Zapisad I zarchiwizowad konfiguracje
Skonfigurowad stacje koocowe
Przetestowad poprawnośd działania modelu (ping, tracert, show ip route)
SPRAWOZDANIE
W sprawozdaniu należy zamieścid:
o
o
o
o
Wybraną adresację wraz z uzasadnieniem
Pliki z wynikami pracy w programie Packet Tracer
Wyniki symulacji
Pliki konfiguracyjne routerów (show running config, show startup config)